Star Citizen 3.0 MEGA THREAD! Post your shit in here!

Jan 31, 2016
645
2,813
800
RSI Handle
AstroGimp01
Just enjoyed the most epic fail in my history of SC.

Decided I would logon and give trading a shot, called up the Cutty Black, loaded it full of alcohol, because TEST.

Got out to the pad and no Cutty Black, my tracker says it is above me, I look up and what to my wandering eyes should appear, but my fist fucking Cutty Black full of alcohol slowly spinning out into deep space, and it is already almost 700m away.

ScreenShot0063.jpg

I clenched my incredibly strong buttcheeks tightly, and ran to the edge of the platform and jumped after it, because, TEST.

I had to use the suit jet in afterburner to catch it, took literally 10 minutes. I was so engrossed in the attempted rescue, and because all my fingers were fully occupied trying to stay in close proximity I failed to get any closing images, sorry.

I synced up to it all Interstellar style, and first managed to open a side door, and was like, holy shit I am going make this work.

But it kept spinning and I kept bouncing off the hull, but I kept after it, because TEST.

I managed to time it and flew inside, the artificial gravity took, and I was in.
ScreenShot0065.jpg

I made my way to the cockpit, jumped into the pilots seat, hit the Flight Ready and Engine On buttons, the computer voice came on, but nothing, no displays, no controls, tried a hard reset on the swtiches a couple times to no avail.
ScreenShot0066.jpg


Tried to activate the self destruct to no avail, because, TEST.

Had to exit to menu and ended with a crash to desktop and here I am, telling the tale of the Cutty Black full of alcohol that got away.

I love this glitchy, 8 FPS PTU, soo much. My heart rate was elevated, not in game, in my chair in my office at home - it was FULLY immersive, and even though I lost 50,000 AUEC worth of alcohol, I actually truly enjoyed the challenge. Not sure I'd have been so reckless in my attempt with permadeath on the line, but it was sure as hell fun.

Once I upograde my graphics card I may have to see about being able to record, because set to Interstellar music, or any of the SC music, that would have been an awesome fiction short.

'Gimp

Edited to add - Even though the Cutty Black was MIA when I logged in and I had to make an insurance claim, I went to the Trading portal and was able to sell back the alcohol from the missing Cutty Black, financial losses avoided and maximum fun levels attained.
 

Attachments

Last edited:
Feb 22, 2016
417
1,285
610
RSI Handle
Lorddarthvik
Soooo, today we got the patch titled "ag" and it's kinda gone very bad for me. The framerates are amazing, instead of 10 I got 50!!! when spawned in the bed, that went down to a perfectly playable 30-35 by the time I got down to the ship spawning room in Olisar.

But. My mouse is now useless. Even in the game menu after starting up the game, I can't hit the buttons, and it's the same in-game, even when using the "f" interaction with the ship console and such. For some reason the main menu is blurry as a steamed up bathroom mirror, and it's like the "interaction overlay" where you have to click, have moved to the right and down compared to where the buttons are drawn! This means I can't reach the menu buttons like Options on the start screen with my mouse.
I managed to get to it using the keyboard, changed the resolution to 1680x1050, and that solved the issue. Changing back to 1920x1080 caused the same problems, so I'll try to play in the lower res, although 16:10 resolutions were broken since forever. I wonder if the game thinks it's running on my second monitor, which is 1680x1050 and that's why it's broken?
But first I gotta do work dammit... I wanna play so much now that the framerates seem to be at a usable level :smile:
 

Pug76

Commander
Nov 21, 2017
142
628
100
RSI Handle
Pug76
I've decided to rename the Aurora the Hippo why ? coz flying it in Atmosphere is like it has a herd of Hippo's in the bay dancing to a 70's disco tune

Oh I got to Leski , finally today ...erm the bs'tard hanger thingy let me land then destroyed my ship , so that's 3 ships destroyed this week , how the hell do i retrieve them ffs ?

p:s this also happened when i logged into Olisar

So I was a bit peeved

 
Last edited:

Rear_Intruder

Vice Admiral
Jun 9, 2017
422
1,667
450
RSI Handle
Rear_Intruder
I have just managed 65 mins (and counting) in build 678451. I initially selected EU an got a 30007, then selected best and got in. No spikes RAM is stays at around 5.4 GB usage, Before it was 7.3 +. (I asked in chat I am in the EU server time here 1500hrs UTC)
FPS has been around 29, It did fall to single figures, for a few secs.

I can not carry a box up the ladder of the 315P it just falls to the ground. was the inly issue



OH NO -- nearly two hours in FPS dropped to 4 FPS-- no freezes at all though
 
Last edited: